Update from 0.9.0 to 0.10.0

Due to major structural changes, the most recent silecs-eclipse-plugin does not support silecs 0.9.0 classes/deploys any more.

You need to do the following:
  1. The folder of the beta-release is now version-specific. So please enter the following path into the preferences:
    • Local Silecs Workspace: "/common/usr/cscofe/silecs/0.10.0"
  2. In order to move your silecs-projects to 0.10.0, right-click on the project in the project-tree and select Update SILECS version. This should transform your documents to the 0.10.0 format ( a backup of the old doc will be done).
  3. You will need to re-generate the code and the PLC-files. The Old silecs-header had the device-name '0'. The new one is named 'SilecsHeader', so you need to rename the Data-Block on the PLC acordingly.

How to get started

On any problems, please dont hesitate to contact the silecs-support: silecs-support(AT)gsi.de

  1. The SILECS developemt environment is located on the asl-cluster. In order to work there you will need to get an user-account there.
  2. Make sure you have java 8 or higher installed:
    user@machine:~$ java -version
    java version "1.8.0_XX"
  3. Install the FESA Eclipe plugin
  4. Install the SILECS Eclipse plugin
  5. Configure the silecs-base-path
    • Window --> Preferences --> Silecs
    • Fesa Base Path: "/opt/fesa"
    • Fesa Version to use "3.0.0" ( no support for 3.1.0 so far ! )
    • check the box "use local workspace"
    • Local Silecs Workspace: "/common/usr/cscofe/silecs/0.10.0"
  6. Create a new silecs-design
    • File --> New --> Project --> Silecs --> Design
    • Enter a name and keep the silecs-version 0.10.0
    • Add some Blocks / Registers to the file, according to your PLC-configuration
    • Press on the icon validate-document.gif "SILECS Validate" to check that the xml-document is valid
      • If it is not valid, first fix remaining problems. Go to the "source"-view and hover the mouse over the error to see details.
    • Press on the icon generated-code.gif "SILECS generate code" to generate the according FESA-class
      • Pick the empty-template, if you are new to FESA
      • If you plan to build a productive class, pick the GSI-Template
      • The project is now both, a FESA-Project and a Silecs-project
    • the related SILECS C++ code will be generated into the "common" folder of the FESA-class. Make use of it in the actions of your FESA-class, according to your needs.
    • Modify the generated FESA-class, according to your needs ( Check the FESA Wiki for help on that ! )
    • Compile the class ( Press on the target "make all" in the eclipse make-target view )
  7. Create a new silecs-deploy
    • File --> New --> Project --> Silecs --> Deploy
    • Enter a name and keep silecs-version 0.10.0
    • Add your silecs-class in Deploy-Classes
      • Replace "device-number" with device-list by right click, and add names for your PLC-device(s) on which you want to run the software
    • The class "SilecsHeader" always needs to be present. Please download it from:
    • Below /Deploy-Unit you have to select your PLC-model (right-click --> replace-with --> ... )
    • In /Deploy-Instances you can add different Controllers(PLC's on which your software should run) .. it does not matter which domain you pick
    • Press on the icon validate-document.gif "SILECS Validate" to check that the xml-document is valid.
      • If it is not valid, first fix remaining problems. Go to the "source"-view and hover the mouse over the error to see details.
    • Press on the icon generated-code.gif "SILECS generate code" to generate the according FESA-Deployment-Unit
      • The project is now both, a FESA-Project and a Silecs-project
      • in generated/controller the files which have to be loaded into the PLC(s) can be found. Use your PLC-specific-software to do so!
      • Start all PLC's on which you want to use the new configuration
    • Modify the generated FESA-Deployment-Unit, according to your needs ( Check the FESA Wiki for help on that ! )
    • Compile and link the deployment-unit ( Press on the target "make all" in the eclipse make-target view )
  8. Test your setup
    • First connect to the PLC by using the SILECS Diagnostic Tool
      • While you are in the silecs-deploy file, press on the icon diag-tool.gif "SILECS Diagnostic Tool"
      • Pick the class you want to test
      • Pick the host you want to test and press ConnectPLC
      • Press sent / receive on the different Data-Fields to check if the connection is working
    • Second connect to the PLC using the FESA-binary
      • Please refer to the FESA Wiki for help on that !

On any problems, please dont hesitate to contact the silecs-support: silecs-support(AT)gsi.de

Topic attachments
I Attachment Action Size Date Who Comment
diag-tool.gifgif diag-tool.gif manage 197 bytes 07 Mar 2016 - 11:00 AlexanderSchwinn  
generated-code.gifgif generated-code.gif manage 591 bytes 07 Mar 2016 - 11:00 AlexanderSchwinn  
validate-document.gifgif validate-document.gif manage 76 bytes 07 Mar 2016 - 11:00 AlexanderSchwinn  
Topic revision: r6 - 17 May 2016, AlexanderSchwinn
This site is powered by FoswikiCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding Foswiki? Send feedback